MD Central Vacuum Since 1961 Fast Free shipping
on orders over $75 ⓘ
Call 1-800-997-2278 Dealer My Order Cart
COVID-19 Notice: We’re shipping as normal. Call & email response times may be delayed.

Eureka Central Vacuum Q&A

Search Answers

Results from Eureka Central Vacuum

Questions
Answers
Questions & Answers

Circuit Board Replacement for CV2101X?

I have the Eureka "the Silencer" CV2101X and it will not shut off even with the low volt wires off. Which relay or board do I need to order; this unit is not listed?

Answer:
Great job identifying the issue with your central vacuum system. We recommend part #235S Vacuum Motor Circuit Board as the proper replacement board for your Eureka model CV2101X. Please note, modifications to your unit (such as drilling an additional hole) may be required for proper mounting.

W G S 5953 Eureka Bag Replacement

We have a eureka central vac - model number CV1001D. Can you please let me know where I can find bags for this. Our previous bag number was W G S 5953

Answer:
We show this bag as the correct replacement for that model https://builtinvacuum.com/retail/shopretail.php?part_no=723EB

Low Suction CV2002-B

what kind of filter would i need for a cv2002B mega boss central vac? it used to have mega power and lift up carpet and now wont pick up a feather.

Answer:
Sorry, we don't have a cross reference for that but it really shouldn't be the filter that is making it weak. In fact, you can remove the filter and test the suction. For other suction issues see www.builtinvacuum.com/flowchrt.html

Keeps Running Without Hose or Low Volt

I have an eureka CV 1001D and the motor keeps on running even if the vacuum hose is not connected and the low voltage wires are disconnected. I have to unplug from the wall outlet to shut it down. What could be the problem. Thanks

Answer:
The relay is bad or there is an on/off switch on the tank that is in the "on" position. If you need a relay see if our 235S would be a good replacement. https://builtinvacuum.com/parts/electrical/boards.html. You can replace all the individual components with a single circuit board.

Go Filterless?

I have a eureka maxima and my filters always clog with dirt my question is can I use the sweeper without the filter ? Miranda walton wv

Answer:
Sorry, you have to use the filters to keep the motor from getting debris in it. There should be a bag and a disk filter which leave the disk filter cleaner that what you are describing. The filter is here https://builtinvacuum.com/retail/shopretail.php?part_no=723EB

Silencer Ironsides

I have the Central vacuum called eureka the silencer Ironsides. What would be the best power head to have. Take into consideration I have pets

Answer:
The best vacuum head would be the Stealth, then the Ace. Hopefully you are in a position to buy the kit that includes the brush and the hose along with the connection wands so they all fit together correctly. If you need help determining if your current hose will work please call us. Here are the complete kits https://builtinvacuum.com/help/eureka/kits.html

No Suction for Floor Tools

My power head is working but when I take it off to vaccuum the wood floor, the hose and attachment won't start. So when the plug is out and the head is off, nothing works.

Answer:
It may be that the vacuum nozzle is working but the suction isn't. The sound of the nozzle sounds like the air is on too but it may not be. Without the nozzle connected, see if there is suction when the switch is put in the right and left positions. Use our troubleshooting guide https://builtinvacuum.com/help/eureka/flowchart.html if there is no suction in either or replace the switch if there is suction on only one side https://builtinvacuum.com/retail/shopretail.php?part_no=352GS,352GH.

Clicking Noise, No Suction

I have a Eureka megaboss central vac that just stopped working. I took the cover off because I heard a clicking noise when I tried turning it off and on. I noticed there was a little burnt location on the circuit board. Could that be the cause? If so, is it possible to order a new circuit board?

Answer:
When you turn the vacuum on and off there should be a clicking noise at the tank. That is the relay transferring the power to the motor. Most likely the motor is out. Whack the motor and try again to see if it starts (it may shut off soon after because it is bad). Let us know what you find.

CV1801N Bad Motor or Breaker?

I have a Eureka Altima CV1801N and it was running fine up until a couple of days ago, now it doesn't see to be getting any power (both the Red and Green lights are not lit). I have tested the outlet and it is find. There is a threaded button on the unit and I have unscrewed the washer around it and tried pushing it in - it just pops out. I am assuming that is a reset of some sort. The unit came with the house and a search for a manual on the unit has proved fruitless. Is the motor shot? Is there another "reset" or test that I am missing?

Answer:
It sounds like the minibreaker has sprung which is usually due to a bad motor. However the breaker may go bad too especially after the motor goes bad. Here are the parts we propose it would take to get the unit running, or you can spend hundreds more for a new vacuum unit complete. https://builtinvacuum.com/retail/shopretail.php?part_no=199,221,235S If you want a new vacuum unit you can use any brand and we recommend the Flo-Master C650 https://builtinvacuum.com/flomaster/compare.html

Spits Debris from the Head

I have a Eureka Boss Quiet Kleen Ctl Vac.The brush wand works & has suction from the hose.The powerhead spits back dust/pet hair/whatever it picks up.I took the powerhead for service.They replaced the belt & said it works fine.I still have the same problem as B4.I borrowed another working powerhead to test it at my home & it also spits everything back.I emptied the cannister & shook the attached bag to have the dirt/hair/dust fall into the cannister & it doesn?t help.It's a mystery why the brush wand & hose w/o attachments work but the powerhead doesn't pick up properly & spits everything back.I have a cat & 2 shedding dogs with a lot of carpet to do which is tough with just the brush.Pls advise/suggest ASAP as to what could B wrong or what can B done.Thx

Answer:
This usually means there is no suction in the right switch position. Without the wands and head on the hose handle try the right position switch to see if there is suction. If not, replace the switch. Is there is then check the wands for a clog.

World Vac Not Working

Eureka World Vac suddenly won't turn on I have a World Vac Cv1601 B that won't turn on. No lights either. Tested the outlet is fine. Tried the reset button, all to no avail. It had turned off the last time I had used it but the reset button worked. Now it won't reset. Any thoughts? Thanks, Matt - Toronto

Answer:
If it will not reset then the motor and most likely the reset button (circuit board) need to be replaced. https://builtinvacuum.com/retail/shopretail.php?part_no=199,221,235S,how2mtr&title=Motor+for+Eureka Please do a visual check to be sure the motor is correct.

Boss Not Starting

I have a Eureka boss model# ECV2002A vacuum wont turn on. motor works fine. I have a feeling the board is my problem. Any sujestions

Answer:
Please use this guide for help www.builtinvacuum.com/flowchart.html

Cloth and Paper Filter in Same Unit

I HAVE A EURUKA QUIET CLEAN MODEL PU3650B. IT HAS A PERMANENT, WEIGHTED, CLOTH FILTER, AND PAPER BAGS. IS THE PAPER COLLECTION BAG NECESSARY?

Answer:
You don't need both if you only use the cloth one, BUT if you want the paper bag you have to use both because the cloth acts as a precautionary filter if the paper breaks.

Connections Burning Out

I am having problems with my carpet beater. The plug on the carpet beater and the plug that attaches to the hose overheats and is melting the plastic or rubber aroung the connections. Is this common? When turning carpet beater on do you have to shut vacuum to off position first (if you are using regular floor vacuuming) before switching to carpet position. I can smell rubbering buring and my electrical connections look burnt. Would this be an arching problem. Has there been any recalls for the problem. brenda bc canada

Answer:
This is not an uncommon area of failure as the vacuum ages. You may be able to replace the parts themselves. Please send us photos of the parts so we can help.

Eureka Exhausting Dust

hello, I have a eureka powerline limited edition in a house we bought. when I open the can and empty it, pulled the cloth filter out and cleaned it, put everything back the way it was and now dust coming out of the exhaust into the garage? I've made sure everything is back the way it was but still can pin point why is it happening? thank you, Dan Thornhill Ontario

Answer:
Either the bag is in the wrong position and below the intake on the unit, or there is a hole in the bag allowing dust to go through.

Hose Activates Suction Only To One Side

i have a the boss 550 eureka central vac canister,and an imperium tool kit 35ft pigtail hose and a sebo power head( both of which i purchased online from here)my problem is the motor on the canister central vac is not running when i switch on the sebo power bar the power bar runs but there seems to be no pick up or power for suction and the motor on the central vac canister is not running yet when i switch over to floor there is suction and the central vac motor starts to run is this a problem in the handle switch i hope not it was only year old in november thanks Anita Wanless,Manitoba Canada

Answer:

You have a bad switch in the handle. It is only making the needed connection to activate the power unit on one side but not on the other side and it needs to be replaced. We have possible replacement switch assemblies on our website for review. If the hose is only a year old, it may still be under warranty. Contact the company or dealer where the hose was purchased for information.

Muffler Came Off Unit

Have you ever heard of a muffler blowing off. If so, what would cause this?

Answer:
If the muffler is not secured to the exhaust or has some obstruction in it, the pressure of the escaping air will push it off. Be sure that the muffler is tight on the unit exhaust or pipe extension. Check the inside of the muffler to ensure that there is nothing inside that can be reducing air flow.

Eureka CV1801D Filter

is there filter in the cv1801d? thanks

Answer:
Yes, the cloth bag that is hanging down when you remove the bottom canister is the filter. You can replace it with the bag found here, https://builtinvacuum.com/retail/shopretail.php?part_no=710B,711B

Eureka Model 1460 Won't Pick Up Dirt

mary miss.eureka model460 styleAZ DOES not pick up dirt

Answer:
This could be an issue with the floor tool or the vacuum itself. Follow our troubleshooting guide to narrow down the issue at https://builtinvacuum.com/education/troubleshoot.html

Buy Hose and Head Separately?

I have a Eureka central vac CV1820B. Can I buy a new hose and power head for it because the motor and acc. are doing fine?

Answer:
Actually, the hose, head and connecting wands all cost more if bought alone than in a complete kit. We recommend the kit for this reason and so that the wands fit the head and hose correctly. The accessories you already have will fit the hose and wands. Here is the kit page for Eureka https://builtinvacuum.com/help/eureka/kits.html

Eureka CV18 Unit Working But No Suction

My Eureka CV MCU 18 was working fine, and suddenly has very little suction... the hose is not blocked and all inlets are closing properly... the motor turns on when I plug the hose in, but makes no noise at the inlet and has very little suction... the cannister and hanging cloth filter are clean... any ideas? Andrea

Answer:
If your power unit is turning on normally and there is strong suction right at the unit but no suction at the inlets, then you have a clog. You will need to contact your local repairman to have the pipeline cleared. https://builtinvacuum.com/dealers.html

Unit Not Turning On

The 24 volt circuit light is on. But the vacuum is not turning on. Its 12 years old.

Answer:
You may have an issue with the motor, or with the hose not activating the unit. Follow our trouble shooting guide to narrow down the problem at https://builtinvacuum.com/education/troubleshoot.html

Boss Reset Button

i have the eureka 12 amp The Boss wide track: the carpet brush just stopped spinning...is there a reset button to fix that?

Answer:
We have no information on The Boss. You can contact Eureka 800-282-2886 for information.

Most Outlets Not Activating The Vacuum

Jim from toronto I have a ECV2002A Meg Boss central vac.The machine does not come on from any of the 4 outlets in the house (no power). It only work from the outlet next to the vacume in the garage. how can i solve this problem?

Answer:
If one of your inlets works, but the rest do not, then there is a break in the wires. Start at the inlet that is working and follow the wire to check all connections. Over time the low voltage wires that connect the inlet to the unit can work themselves loose.

Unit Louder After Cleaning The Filter

we have a eureka boss plus built in vac system. i just cleaned the filter outside. now the unit is 3 times as loud. any suggestions ? dave in oliver, b.c canada

Answer:
Double check your exhaust, it may be blocked causing the motors to run louder.